Xuyuanp/yanil

github github
file-explorer plugin
star 61
stars
alert-circle 2
open issues
users 1
subscribers
git-branch 3
forks
CREATED

2020-09-29

UPDATED

8 days ago

packer

require('packer').startup(function()
  use 'Xuyuanp/yanil'
end)

paq

require "paq" { 
  'Xuyuanp/yanil'
}

Yanil

Yet Another Nerdtree In Lua

This not an out-of-box nerdtree alternative (and won't be), but a lib to build your own nerdtree.

Prerequisites

  • neovim-0.5.0 or higher.

Installation

Plug 'Xuyuanp/yanil'

Setup

It's not very easy to make it work (It's just a lib). A sample config can be found in my personal dotfile.

Note

This plugin is in very early stages and has no backward compatibility guarantees.

Known issues

  • Not support for windows
  • Not support for multi tabs
  • ...

Credits

  • nerdtree: It's one of the greatest vim plugin.
  • nvim-tree.lua: I learned a lot from it in prototype stage.