anott03/nvim-lspinstall

github github
lsp-installers plugin
star 81
stars
alert-circle 5
open issues
users 3
subscribers
git-branch 5
forks
CREATED

2021-01-05

UPDATED

4 days ago

packer

require('packer').startup(function()
  use 'anott03/nvim-lspinstall'
end)

paq

require "paq" { 
  'anott03/nvim-lspinstall'
}

nvim-lspinstall

What is it?

Recently, neovim removed the :LspInstall function. It made it really easy to install language servers for its built in lsp, so I'm making a replacement!

Installation

You can install nvim-lspinstall with any neovim package manager.

Plug 'anott03/nvim-lspinstall'

Ultimate Language List

These are the langauges we plan/hope support. It's the same list that was on the lspconfig github page.

  • als
  • angularls
  • bashls
  • ccls
  • clangd
  • clojure_lsp
  • cmake
  • codeqlls
  • cssls
  • dartls
  • denols
  • dhall_lsp_server
  • diagnosticls
  • dockerls
  • efm
  • elixirls
  • elmls
  • flow
  • fortls
  • gdscript
  • ghcide
  • gopls
  • groovyls
  • hie
  • hls
  • html
  • intelephense
  • jdtls
  • jedi_language_server
  • jsonls
  • julials
  • kotlin_language_server
  • leanls
  • metals
  • nimls
  • ocamlls
  • ocamllsp
  • omnisharp
  • perlls
  • purescriptls
  • pyls
  • pyls_ms
  • pyright (not working)
  • r_language_server
  • rls
  • rnix
  • rome
  • rust_analyzer
  • scry
  • solargraph
  • sorbet
  • sourcekit
  • sqlls
  • sumneko_lua
  • svelte
  • terraformls
  • texlab
  • tsserver
  • vimls
  • vuels
  • yamlls
  • zls