novakne/kosmikoa.nvim

github github
treesitter-colorschemes plugin
star 24
stars
alert-circle 0
open issues
users 1
subscribers
git-branch 1
forks
CREATED

2021-03-06

UPDATED

3 months ago

packer

require('packer').startup(function()
  use 'novakne/kosmikoa.nvim'
end)

paq

require "paq" { 
  'novakne/kosmikoa.nvim'
}

Kosmikoa

Dark colors scheme for Neovim

Requirements

  • Neovim > 0.5
  • Tree-sitter - Optional but highly recommended
  • Polyglot - Optional, you could look at what plugins they use for the languages you like though

Have a look at kosmikoa.extras for config for terminal and other tools

Install

Use your favorite plugin manager.

e.g. packer.nvim

use {
    'https://git.sr.ht/~novakane/kosmikoa.nvim',
    -- you can require it directly here
    config = function()
        require'kosmikoa'
    end,
}

e.g. vim-plug

Plug 'https://git.sr.ht/~novakane/kosmikoa.nvim'

Usage

lua require 'kosmikoa'

or

colorscheme kosmikoa

Support

Languages

  • All maintained Tree-sitter parsers
  • c/c++
  • clojure
  • css
  • fennel
  • go
  • html5
  • javascript
  • json
  • jsx
  • less
  • log
  • lua
  • markdown
  • moonscript
  • nim
  • python
  • rust
  • scss
  • sh
  • toml
  • typescript
  • xml
  • yaml
  • zig

Plugins

A lot of plugins should be good if they link colors to defaults neovim groups.

Contributing

The main repo is at sr.ht use it in priority.

Send patches or question using git send-email to my public inbox ~novakane/public-inbox@lists.sr.ht with project prefix set to kosmikoa.nvim.

git config sendemail.to "~novakane/public-inbox@lists.sr.ht"
git config format.subjectPrefix "PATCH kosmikoa.nvim"

Or if you're on Github use Github interface.

Format the code with StyLua.

I mostly use c, zig, lua and sh so if you want to improve other languages feel free to send a patch or a request so I can look a it.

License

MIT