yazeed1s/minimal.nvim

github github
tree-sitter-supported-colorscheme
star 51
stars
alert-circle 1
open issues
users 1
subscribers
git-branch 2
forks
CREATED

2022-07-15

UPDATED

3 days ago


minimal.nvim

Two TreeSitter supported colorschemes ispired by base16-tomorrow-night and monokai pro.
Both colorschemes are availaible for vim and neovim and written in Lua.

✨ Features

  • support the latest Neovim >=5.0 features like TreeSitter and LSP
  • darker background for sidebar
  • color configs for Kitty and Alacritty. Created by miguelaht.

📌 Note:

Both colors are designed with Go and Rust in mind, and tested against few other languages.
If any of the colors does not syntax-highlight your langauge satisfactorily, please feel free to fork the repo and do changes as needed.
#

⭐️ [minimal-base16]

screenshot_1 screenshot_2 screenshot_3 screenshot_4

⚡️ [minimal]

screenshot_1 screenshot_2 screenshot_3 screenshot_4

✅ Plugin Support

👇 Requirements

  • Neovim >= 0.5.0

📦 Installation

You can Install the theme with any of the following package managers:

vim-plug

Plug 'Yazeed1s/minimal.nvim'

packer

use 'Yazeed1s/minimal.nvim'

🚀 Usage

Enable the colorscheme:

" Vim Script
colorscheme minimal " for minimal
colorscheme minimal-base16 " for minimal-base16
-- Lua
vim.cmd[[colorscheme minimal]] -- for minimal
vim.cmd[[colorscheme minimal-base16]] -- for minimal-base16
-- or, for lunarVim
lvim.colorscheme = 'minimal'
lvim.colorscheme = 'minimal-base16'

👇 For terminal use:

Color configs for Kitty and Alacritty can be found in terminal. If you want to use them, pleas refer to their respective documentation and do changes to your .config/ accordingly

✅ TODO:

🔥 Contributing

If you would like to add support to a plugin or to fix a bug please feel free to send a PR.

💐 Credits